DICAS NO EXCEL

FÓRMULAS USADAS NESTE VÍDEO

Criar uma sequência numérica na coluna

=L1+1

Copiar valores nas células vazias

SE(J6=””;M5;J6)

Fórmulas usadas neste vídeo

Escrever o nome do mês – SE()

COLOCAR NOME DO MÊS

=SE(E5=1;”JANEIRO”;SE(E5=2;”FEVEREIRO”;SE(E5=3;”MARÇO”;SE(E5=4;”ABRIL”;SE(E5=5;”MAIO”;SE(E5=6;”JUNHO”;SE(E5=7;”JULHO”;SE(E5=8;”AGOSTO”;SE(E5=9;”SETEMBRO”;SE(E5=10;”OUTUBRO”;SE(E5=11;”NOVEMBRO”;SE(E5=12;”DEZEMBRO”;””))))))))))))

 

 

COLOCAR NOME DO DIA DA SEMANA

=SE(AQ18=””;””;SE(DIA.DA.SEMANA(AQ18)=7;”SÁBADO”;SE(DIA.DA.SEMANA(AQ18)=6;”SEXTA”;SE(DIA.DA.SEMANA(AQ18)=5;”QUINTA”;SE(DIA.DA.SEMANA(AQ18)=4;”QUARTA”;SE(DIA.DA.SEMANA(AQ18)=3;”TERÇA”;SE(DIA.DA.SEMANA(AQ18)=2;”SEGUNDA”;SE(DIA.DA.SEMANA(AQ18)=1;”DOMINGO”;”DIA)”))))))))

 

Somar vendas com critérios – SOMASES()

=SOMASES(IMPORTAÇÃO!I:I;IMPORTAÇÃO!J:J;ANALISE!$C$5;IMPORTAÇÃO!N:N;ANALISE!B6;IMPORTAÇÃO!O:O;ANALISE!$C$1)

 

Somatória da coluna – SOMA()

=SOMA(C6:C36)

 

Percentual de participação = DIVISÃO PURA

=D4/$N$4

FÓRMULAS USADAS NESTE VÍDEO

1- Conta quantos pedidos foram emitidos pelo vendedor por dia dentro do mês

=CONT.SES(IMPORTAÇÃO!J:J;AULA!$D$3;IMPORTAÇÃO!N:N;AULA!B5;IMPORTAÇÃO!O:O;AULA!$D$2)

 

2-Soma as vendas do vendedor por dia dentro do mês.

=SOMASES(IMPORTAÇÃO!I:I;IMPORTAÇÃO!J:J;AULA!$D$3;IMPORTAÇÃO!N:N;AULA!B5;IMPORTAÇÃO!O:O;AULA!$D$2)

 

3-Calcula valor médio dos pedidos emitidos por dia.

opção 1 -> =SE(C5=0;0;D5/C5)

opção 2 -> =SEERRO(D5/C5;0)

 

4-Soma as vendas do vendedor no mês

=SOMA(D5:D35)

 

5- Soma quantidade de pedidos emitidos pelo vendedor no mês

=SOMA(C5:C35)

 

6-Calcula valor médio dos pedidos do vendedor

=SOMA(C5:C35)

 

7- Calcula média diária de vendas usando apenas dias trabalhados.

=E39/CONT.SE(C5:C35;”>0″)

 

8- Calcula participação do vendedor dentro das vendas do mês

=E39/E47

 

9- Pesquisa e mostra nome do vendedor

=ÍNDICE(ANALISE!C2:M2;CORRESP(PESQUISA!D3;ANALISE!C5:M5;0))

 

 

 

 

 

SCRIPT DA MACRO PARA COPIAR DADOS DE UMA PASTA PARA OUTRA

Sub COPIAR()
Sheets(“IMPORTAÇÃO”).Select
Range(“A2:L203”).Select
Selection.Copy
Sheets(“PESQUISA”).Select
Range(“C5”).Select
Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
:=False, Transpose:=False
Range(“C5”).Select
End Sub

 

 

SCRIPT DA MACRO PARA LIMPAR DADOS DE UMA ÁREA DA PLANILHA

Sub LIMPAR()
Range(“C5:N208”).Select
Selection.ClearContents
Range(“L5:Q208”).Select
Selection.ClearContents
Range(“C5”).Select
End Sub

SCRIPT DA MACRO PARA IMPRIMIR  (COM AJUSTE DE LAYOUT)

Sub IMPRESSAO()

Range(“B1:W36”).Select
ActiveWindow.SmallScroll Down:=-27
ActiveSheet.PageSetup.PrintArea = “$B$1:$W$36”
ActiveWindow.SmallScroll Down:=-9
Range(“F11”).Select
Application.PrintCommunication = False
With ActiveSheet.PageSetup
.PrintTitleRows = “”
.PrintTitleColumns = “”
End With
Application.PrintCommunication = True
ActiveSheet.PageSetup.PrintArea = “$B$1:$W$36”
Application.PrintCommunication = False

‘AJUSTA LAYOUT DA IMPRESSÃO
With ActiveSheet.PageSetup
.LeftHeader = “”
.CenterHeader = “”
.RightHeader = “”
.LeftFooter = “”
.CenterFooter = “”
.RightFooter = “”
.LeftMargin = Application.InchesToPoints(0.511811024)
.RightMargin = Application.InchesToPoints(0.511811024)
.TopMargin = Application.InchesToPoints(0.787401575)
.BottomMargin = Application.InchesToPoints(0.787401575)
.HeaderMargin = Application.InchesToPoints(0.31496062)
.FooterMargin = Application.InchesToPoints(0.31496062)
.PrintHeadings = False
.PrintGridlines = False
.PrintComments = xlPrintNoComments
.PrintQuality = 300
.CenterHorizontally = False
.CenterVertically = False
.Orientation = xlPortrait
.Draft = False
.PaperSize = xlPaperLetter
.FirstPageNumber = xlAutomatic
.Order = xlDownThenOver
.BlackAndWhite = False
.Zoom = False
.FitToPagesWide = 1
.FitToPagesTall = 0
.PrintErrors = xlPrintErrorsDisplayed
.OddAndEvenPagesHeaderFooter = False
.DifferentFirstPageHeaderFooter = False
.ScaleWithDocHeaderFooter = True
.AlignMarginsHeaderFooter = True
.EvenPage.LeftHeader.Text = “”
.EvenPage.CenterHeader.Text = “”
.EvenPage.RightHeader.Text = “”
.EvenPage.LeftFooter.Text = “”
.EvenPage.CenterFooter.Text = “”
.EvenPage.RightFooter.Text = “”
.FirstPage.LeftHeader.Text = “”
.FirstPage.CenterHeader.Text = “”
.FirstPage.RightHeader.Text = “”
.FirstPage.LeftFooter.Text = “”
.FirstPage.CenterFooter.Text = “”
.FirstPage.RightFooter.Text = “”
End With

‘ IMPRESÃO
Application.PrintCommunication = True
ActiveWindow.SelectedSheets.PrintOut Copies:=1, Collate:=True, _
IgnorePrintAreas:=False
End Sub

Comando, usado dentro de uma macro,  para fazer o excel falar um texto escrito dentro de uma célula.

Range(“P2”).speak

 

 

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

*